Honda Foreman Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter · #1 ·
I was 2 miles back in on a logging road yesterday when I dropped into a small mud puddle and when I came out the Rubi just died and backfired like the kill switch was hit which is exactly what I thought happened. Checked everything out and tried to start. Engine just cranks like there is either no spark or no fuel. Tank is 1/2 full and Rubi was running fine for previous hour. Had to be towed out by my nephew with his yamaha kodiak. Any thoughts? Angle sensor, TPS, Gear shift sensor, etc. The screen has no faults flashing. Everythings appears fine.
 

·
Registered
Joined
·
1,397 Posts
Check for spark at the plug and if that's o.k. then screw in a new sparkplug and see if it's getting gas.Any prior problems?
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #4 ·
Three weeks ago no power and screen flashing codes. Brother turned if off and restarted and everything cleared up. Two months ago new plug, valves adjusted, new gear oil, air filter cleaned. Trouble free normally.
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #6 ·
We've had a lot of rain the last month in northern Wisconsin but I don't think at any time it was more than a couple inches over the foot wells. Mostly water. I use it strictly for hunting at this time of year and was going slow with a load of gear.
 

·
Registered
Joined
·
152 Posts
It kinda sounds like you have picked up water in your carb but if the water was only a few inches over the foot pegs then it shouldn't be that. But just in case you might want to drain your carb bowl anyway just a thought.
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #8 ·
The ECM went out on me. $284 later and it is now running. Took 1 week to get from the warehouse. This along with the new timing chain and tensioner on my 450 foreman for $600 three weeks ago, I am starting to question "Best on Earth".
 

·
Registered
Joined
·
228 Posts
Discussion Starter · #9 ·
The ECM went out on me. $284 later and it is now running. Took 1 week to get from the warehouse. This along with the new timing chain and tensioner on my 450 foreman for $600 three weeks ago, I am starting to question "Best on Earth".
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top