Honda Foreman Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
anyone have trouble with the side panels not fitting good anymore once removed? i jsut got my bike back from the shop and they dont wanna stay hooked into the black plastic piece in the middle where the gastank is
 

·
Registered
Joined
·
472 Posts
i think this is just true of once you mess with it will never be right again
 

·
Registered
Joined
·
1,123 Posts
this happened to my rubicon, i dont know what fixed it but i just messed with it for a while and it fit perfict when i sold it.
-Aaron
 

·
Registered
Joined
·
154 Posts
QUOTE ("stomper":24brrilk)
anyone have trouble with the side panels not fitting good anymore once removed? i jsut got my bike back from the shop and they dont wanna stay hooked into the black plastic piece in the middle where the gastank is
You got to watch what the shop does. I got mine back and noticed they had bent my front fenders all up. All it took was a little pushing on them, but they had them bent real funny looking. As far as the side pannel, just mess around with your plastics some and it should go back in place.
 

·
Registered
Joined
·
471 Posts
QUOTE ("rubyandforeman":1hyo70i7)
YA I HAD THE SAME.... I JUST TOOK IT OFF AND LEFT IT OFF.. ITS A EASY FIX...
hey ruby

i thought that was my secret fix. ive got 2 panels in my garage and one lost on the trail somewhere.
 

·
Registered
Joined
·
61 Posts
Same problem after adjusting the valves. Took it off again and tweaked it a little, now it squeaks. Took it off yet again only to break the hook off....now it is quiet and fits as good as it ever will!!!!

It is amazing noticing just how many other people have the exact same minor problems I do, I thought it was just my imagination!!
 

·
Registered
Joined
·
98 Posts
i have the same problem
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top