Honda Foreman Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter · #1 ·
Ok so today for the first time in two years i got the bike started. What a good feeling. I changed the oil, oil filter, coolant, battery, cleaned the carb, cleaned the bike, aired the tires, but couldnt take it for a ride (it still has a busted a-arm). Anyways my question is this. Im currently running an HMF exhaust, KN intake, and Dynojet kit. Im running either the 155 or 160 jet. I have the DJ140, DJ150, DJ148, DJ146, DJ144, and the DJ142 left over. Am i running the right jet for my current setup, running 93 gasoline? The bike has SOME trouble staying on and has a low idle which im sure can be fixed with a simple bumping up of the carb. The bike seems sluggish in the mud and i know with all these mods it should feel BETTER than stock and it really doesnt at all. Any and all help is appreciated, im slowly trying to get back into riding! I would also like to know possible reasons why my quad could be overheating after no use for 2 years and a recent coolant change. I cleaned the radiator thoroughly today and still after only an hour long, the red light was on. Thanks guys!
 

·
Registered
Joined
·
206 Posts
Discussion Starter · #2 ·
Im also looking for a front bumper replacement. I removed my busted up one today and only have the front basket on. Who makes complete lower replacement front bumpers?
 

·
Registered
Joined
·
271 Posts
About the bumper look into warn i think it replace the front and about the overheating on mine i would let it sit for say a week and ride it for 5 minutes and the ride light would come on it turned out that i had a hole in the radiator i don't think that could be your problem and what kind of oil are you putting in it
 

·
Registered
Joined
·
206 Posts
Discussion Starter · #4 ·
Im using the standard 10w-40 Honda oil.
 

·
Registered
Joined
·
271 Posts
ok well if you want try running honda 20w-50 thats want i am running its a little thicker
 

·
Registered
Joined
·
59 Posts
Is the fan working?
 

·
Registered
Joined
·
206 Posts
Discussion Starter · #7 ·
The fans are definately working. Im going to take it to Honda and let them figure it out.
 
1 - 7 of 7 Posts
Top