Honda Foreman Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter · #1 ·
I am not sure whats going on here but my brake lights are on constantly now(when switch is on). Not just the running lights but the high stage of the light, even when my lights are off the rear are burning. I checked all the switches to make sure one of them is not stuck. All are loose and seemed to be moving properly. What could I check?
 

·
Registered
Joined
·
560 Posts
Take a wire off each of the 3 brake switches and see if the lights go out or check the switches with a meter. They may look like they move but could still be closed (shorted, burned,seized,) internally.
 

·
Registered
Joined
·
182 Posts
im having the same problem but the front brake has 2 switches and one of them is broke and some how works but the whole this pushed inside causing it to stick on
 

·
Registered
Joined
·
343 Posts
Discussion Starter · #5 ·
QUOTE ("H4":3q7hpspo)
Take a wire off each of the 3 brake switches and see if the lights go out or check the switches with a meter. They may look like they move but could still be closed (shorted, burned,seized,) internally.

I'll give it a shot. Thanks!
 

·
Registered
Joined
·
212 Posts
QUOTE ("rubyandforeman":1ljcxfba)
ya i have the same problem its the brake handle is not goin all the way in to close the circuit.
Was there ever a fix found for this that anyone knows of?
 

·
Registered
Joined
·
290 Posts
i have the same problem. If you pick up on the left brake handle like listed about it might cut off. It is a little nipple in there that the break handle pushes in. But my brake handle has a little slack in it
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top