Honda Foreman Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My 05 foreman 500 es just starts spitting when you gun it from a stop or in third if you dog it in 1st and 2nd, it idles fine, it sparks lite blue, it looks like my filter is clean, my factory snorkel is hooked up right. I would think it has to be the gas line any suggestions? My HMF does have a small leak and I did jet it. Also how hard is it to change the rear brakes.
 

·
Registered
Joined
·
2,679 Posts
Was it running fine after the rejet? is it possible that trash has got in the carb causing your problem?

The rear brakes are pretty simple to work on. I assuming there is no more adjustment left and that is why you are wanting to replace them.

Remove lugs, loosen the rear brake cables on the rear. remove big nut holding the hub on. There are like 8 or so 8mm bolts holding the brake cover on, remove those and there are some slots around the brake backing plate to pop the cover off. after the cover is removed you are looking at the brake drum, it should slid right off. sometimes it can be a pain. make sure to replace the brake cover seal and inspect the bearing while your in there.
 

·
Registered
Joined
·
177 Posts
Whats your spark plug look like? You should try and fix your exhaust leak.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
No it ran fine after I rejetted it there might be some dirt in it I just haven't felt like taking it apart to see. I bought a new plug do you guys know if NGK iridium plugs are pre-gaped but that isn't the problem. Any other guesses thanks for the info on the brakes they do nothing and they are all the way adjusted.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top