Honda Foreman Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Found some oil leaking out of the front of my engine going to the front drive shaft. Anyone else has had this problem or know what to do about it? I was looking for the parts but dont know what it is called. Any advice would be helpful.
Thanks

2007 foreman 500
28"outlaws on Douglas Spyder
hmf exhaust
dyno jet kit
2" hl lift kit
k&n filter
Triangle snorkle
custom beer holder
aluminum product stick stoppers, front skid plate with warn winch and bottom skid plate
AudioTube with Ipod holder
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #2 ·
Part name

I figured out it is the front oil seal. A 3.40 part. Anyone know of the easiest way to change this.

2007 foreman 500
28"outlaws on Douglas Spyder
hmf exhaust
dyno jet kit
2" hl lift kit
k&n filter
Triangle snorkle
custom beer holder
aluminum product stick stoppers, front skid plate with warn winch and bottom skid plate
AudioTube with Ipod holder
 

·
Registered
Joined
·
394 Posts
hope you dont have to take the front diff off the mounts and slide it forward to get the driveshaft out the way, well at least that is the case with me, i broke the bolt that is just under the driveshaft that holds the front case of the motor on
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Thanks, just seems like no other folks have had this problem. Any other advice would be helpful.
 

·
Registered
Joined
·
744 Posts
no alot of people have had this problem with the seal around the front drive shaft its not to hard to do you just need to unbolt the front diff and slide it forward enough to to get the drive shaft away alittle take a pick and get the old one out and then just pop the new one in..........when you take the seal out your going to loose some oil ........... as far as breaking the bolt that holds the front case to the motor dont see why that was even needed to be touched
 

·
Registered
Joined
·
394 Posts
because i had the front cover off to install a clutch kit, unless you happen to know a way to get the springs on without taking the cover off im all ears for that but the damage has been done already to the bolt
 

·
Registered
Joined
·
744 Posts
o okay you had it off to put in a clutch kit but you dont have to touch the front cover to get to the seal that i am talking about maybe i am talking about the wrong one
 

·
Registered
Joined
·
323 Posts
thanks for the right up i have the same problem on my 05 500, just watching the oil right now till my garage gets built
 

·
Registered
Joined
·
394 Posts
yea that was way off topic sorry guys...but i have 27" vamps, when those wear down ima get either a outlaw/vampire combo or get all outlaws...but i dont do a entirely ton of riding, but when i do ride its alot of mud
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top