Honda Foreman Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've had this 86 foretrax for about 12 years. About a year ago while riding it would suddenly act like it was running out of gas while riding. Then it completely stalls. I kick into neutral and it fires right back up. Idles fine. When I shift into reverse or first, it dies . It appears to be an ignition problem. If I leave it parked for a bit it will start and drive fine again. The cdi is a HA7 C1523. I have ordered a couple different ones from ebay and when installed the quad will not start or fuel pump wont run. I was told that it's a cdi for a 350A and they are discontinued. Is there a repair or a replacement for the cdi I have. I was also told that the negative to the cdi was being fed thru the neutal light when the cdi goes bad, that is why when the quad is put in gear it dies. The centrifugal clutch is not causing it to stall. Any help would be appreciated.
 

·
Registered
Joined
·
459 Posts
Sounds like it needs its carb cleaned, and as for cdi I'd look for a ricks cdi... not one from ebay or amazon
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sounds like it needs its carb cleaned, and as for cdi I'd look for a ricks cdi... not one from ebay or amazon
Carb is perfect, rebuilt and clean 6 years ago, idles and runs with full power and perfect idle. It will just shut down without warning when driving it. Then starts back up in neutral. As soon as you put in gear it loses spark, then in neutral starts and runs fine. Drop into 1st or reverse and no spark
 
1 - 3 of 3 Posts
Top