Honda Foreman Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Went to use my winch Christmas Eve and when I hit the switch I got nothing only my relay clicking. So I checked to see that power was going to the winch, and it was. So the I hauled the winch off and took it apart to find that the wire connecting one set of brushes was no longer connected to the bolt/connector on the winch motor.

I bought this winch along with my foreman in august.

Anyone have similar trouble?

I am able to fix it myself but I will send it back to the dealer if it is worth my while and worth the wait.

Any suggestions as to how warn will handle this case? New winch? or will they repair mine which will keep me waiting?

I appreciate the help.
 

·
Registered
Joined
·
422 Posts
I think they repair yours, I would take it back to the dealer and have them fix. That way if thats not the only problem you wouldn't have to do anymore trouble shooting. I have fixed mine once and it last two more rides and now something else went wrong.
 

·
Registered
Joined
·
404 Posts
i got a letter from warn about a recall on some of their winches. I don't even own a warn. Might want to check about the recall.
 

·
Registered
Joined
·
232 Posts
the Warn recall is for the wiring block. You need the new 4 post block. If you have the 6 prong block yor ATV could catch fire.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top