Honda Foreman Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Alright we’ll I’ve looked around and it seems that I’m having a weird problem I replaced my angle sensor in my 05 rancher 350 and it still won’t shift the shift motor is good and I unplugged the ecu and the quad will still run so I don’t even know what to think unless that’s not the ecu under the back right wheel well I’m lost it’s not giving me anything the fues are all good also it seems like I’m not getting any power to the switches or motor but if that is the ecu wouldn’t the quad not start hope someone has some insight thanks y’all
 

·
Registered
Joined
·
1 Posts
I hope someone helps you. I’m having a similar issue with my 420 and am not getting any help. My shifter doesn’t even make noise when you click it up and down. It’s like it has no power. I can manually shift it with a wrench on the front of the motor so it’s. It hung up. Ohmed out the angle sensor and thought it was bad so replaced it and still didn’t fix it. I’m lost right now and don’t know what to do. Dealership said to replace the ECM but I really don’t want to spend $320 if it’s not going to fix it!
 

·
Registered
Joined
·
5 Posts
I had a similar issue with my 05 Rancher a few years back. Problem turned out to be my battery.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
365 Posts
This site is a money maker for it's owners that do not respond or help in any way. atvhonda.com is a free site with old school members who love the machines and not the click profit. If you search it out the same folks own the honda, suzuki, kawasaki and yamaha forums, we are all profit for them on this site with the adds, at atvhonda.com there are no ads and we don't profit on clicks or views on the net.
 

·
Registered
Joined
·
5 Posts
This site is a money maker for it's owners that do not respond or help in any way. atvhonda.com is a free site with old school members who love the machines and not the click profit. If you search it out the same folks own the honda, suzuki, kawasaki and yamaha forums, we are all profit for them on this site with the adds, at atvhonda.com there are no ads and we don't profit on clicks or views on the net.
So you just come here to redirect members to that site?

I have found lots of good knowledgeable members here.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
5 Posts
No, I'm just letting people know where to go to find the proper help.
Just because a site advertises to make money doesn’t mean the users aren’t helpful. If you don’t like this site, no one is forcing you to use it, go hang out at the other site and let people make up their own minds.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
57 Posts
Hey trout brook if you like the other site so much why are you here. You have a newer machine and obviously have no mechanical knowledge to share. Leave this site to the men that actually turn wrenches
 
1 - 10 of 10 Posts
Top