Honda Foreman Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Grizz, my grizzly just started sputtering the other week. Its never done this before but the other week it just started cutting out at about 21 mph. It sounds kind of like its backfiring and cutting out at the same time. Its rideable but it kind of sucks when you try to gas it. Anything you can contribute to help out again?

I changed the plug out today but still the same. The plug color was a whiteish color. I also dielectric greased some connections. Any advice?
 

·
Registered
Joined
·
1,510 Posts
did you put a intake snorkel on it finnaly??? that could be a problem, like its not getting enough air
 

·
Registered
Joined
·
1,510 Posts
no, is your airfilter clean?clean your carb bowl..might have some crap in there
 

·
Registered
Joined
·
4 Posts
QUOTE ("jackpal":1o29j411)
Grizz, my grizzly just started sputtering the other week. Its never done this before but the other week it just started cutting out at about 21 mph. It sounds kind of like its backfiring and cutting out at the same time. Its rideable but it kind of sucks when you try to gas it. Anything you can contribute to help out again?

I changed the plug out today but still the same. The plug color was a whiteish color. I also dielectric greased some connections. Any advice?
Have you been riding in hot weather? check the gas to see if its boiling. Our's does the same thing. (vapor lock)
 

·
Registered
Joined
·
4 Posts
QUOTE ("jackpal":2fxghnag)
I ride in Florida so its mostly hot but the problem occurs even when the bike is cold a week later. Tried cleaning the jets out with "sea foam" but its still the same.
By any chance do you live near Key Largo? Ever been to the "Hump" in Florida City? That is where we ride most of the time. We have a 06 Grizz and we also have problems with it over heating. Took it back to the dealer under warranty and they never did find anything wrong. As I said before, we have the problem with the gas boiling in the line. Most of the time it's in the winter when it's hot and on the dry side. Summer it is really wet at the hump and looks more like a swamp. Lots of good riding!
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #10 ·
I live in Orlando and we ride mostly in central Florida. I don't think it can be a heat problem because the problem happens when the bike is cold also. Its been fine for 2 years and just suddenly started doing this. I'm bringing it to the dealer to have them look at it.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top