Honda Foreman Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hey boys, new to the site,Been riding red my whole life,I was haveing sputtering problems when off chamber in ruts or hills Thought it might be the carb vent issues as it sputters in water but that all checked out,anyone having problems with vaporlock due to the absence of a heat shield by the carb with an aftermarket exhaust?
 

· Registered
Joined
·
106 Posts
Sounds like the same thing i'm trying to figure out mine sputters backing up hill and just started sputtering in water just above idle, i dont know where to start?
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
hey, dirty it even does it just blasting through a little puddle where there is not enough water to bring the carb vent issues into play.I pulled my check valve and it is working fine. all my fluids are good and there does not appear to be any water or dirt in the carb as it runs great going down the road in all gears and rpm ranges.The mechanic said the carb could be vaporlocking due to the outside temp+ the heat from the exhaust but shouldn't the vent take care of this.It sounds like alot of people are having this problemWhat do the techs on this site have to say?
 

· Registered
Joined
·
1,584 Posts
it's because your intake was sucking up steam off of the exhaust.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top