Honda Foreman Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
well i bought a new used 04 honda forman rubicon 500 friday for 3500 with 30 miles on it and i took it out today and went riding with a bunch of people i just did a full service on it friday night and changed all the fluids but the coolent doing it tomarrow but the bike keep overheating like heck today. but i think the thermenstat might be sticking, but the questions i have is what would be a good set of tires to get for digging in mud and dry dirt. ive been looking at the itp mudlights any good. and im gona be in the market for a decent winch thats not gona cost me a arm and a leg to get one. any info would be relly good thanks
kyle
 

·
Registered
Joined
·
89 Posts
mudlights are garbage, my buddy has a set and hates them, they always go flat, they wear down quick and the lugs are separating from the tire. the kenda bear claws are a good all around tire, but if you want a good mud tire thats not to overkill i would recommend the kenda executioners.
 

·
Registered
Joined
·
88 Posts
hey buddy your overheat problem is not the thermostat in most cases. The radiator probably has a lot of mud in it. If you want to clean it really good take the oil cooler off and put a hose to it. This is a problem that happens alot, also make sure the fan is coming on. If you ride alot in the heat I recommend hot wiring the fan to a switch. good luck
 

·
Registered
Joined
·
301 Posts
Well, I have the Mud Lites, and I like them a lot. They are lighter than most mud tires, don't ride too bad, and do well in the mud. The only complaint I have with them is that if you try backing up in really thick mud (the sticky kind with no standing water), they slick over very fast. Other than that, I'll probably get another set of these, or the 589 M/S.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #6 ·
hey thansk guys for the info i took the radiator off monday and cleaned it out and changed the rad fluid with engine ice i run it in all my 4stroke bike with no prolbums and i replaced my thermastat so thats doen and over with about the tires ive been wouldering in the itp 598s were any good they are cheaper but im ride mainley on dirt and mudd a little road to get to the trails but i try and keep my self off the road as much as possible.
 

·
Registered
Joined
·
8 Posts
overheating problem

i have a new 500 2007 rubi and it was over heating the there was no dirt in the rad there was lots of coolant and the fan was comming on i took it to the dealer he could not find nothing wrong ... I was pissed a brand new bike and it was overheating so he the dealer finanly replace every thing in the cooling system and i have not had a problem yet the final conclunision was the thermostat
 

·
Registered
Joined
·
301 Posts
I'd probably get the 589's over my Mud Lites if I could make the choice again, but I'm happy with my Mud Lites though.

And on the cooling issue, I rode for four hours Friday, and the fan only came on a couple of times...it's weird how some people have the overheating issues and some don't. Oh, and it was probably up around 90 degrees Friday, too.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #9 ·
QUOTE ("aaron_c":2r73skza)
I'd probably get the 589's over my Mud Lites if I could make the choice again, but I'm happy with my Mud Lites though.

And on the cooling issue, I rode for four hours Friday, and the fan only came on a couple of times...it's weird how some people have the overheating issues and some don't. Oh, and it was probably up around 90 degrees Friday, too.
i went riding yeasterday and today and the fan was runnignn all the dam time today.
 

·
Registered
Joined
·
301 Posts
QUOTE ("lifted yota":1nnhzng9)
QUOTE ("aaron_c":1nnhzng9)
I'd probably get the 589's over my Mud Lites if I could make the choice again, but I'm happy with my Mud Lites though.

And on the cooling issue, I rode for four hours Friday, and the fan only came on a couple of times...it's weird how some people have the overheating issues and some don't. Oh, and it was probably up around 90 degrees Friday, too.
i went riding yeasterday and today and the fan was runnignn all the dam time today.[/quote]

thats crazy...and no mud clogging radiator or anything? I don't understand what the difference between yours and mine would be...is yours an '06? Then again, I don't really beat on mine or rev it very high unless I'm about to get stuck or something.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #11 ·
no my radiators not clogged it was a while back when i first got it and i spent 2 hours cleaning it and got it ***** and span clean put it back in and changed all the radiator fluid that i could drain in the hole bike and it still ran all day. no mine is an 04 i ran it today after work and after 10 minits of running it the fan was going strong idk whats wrong with it a buddy of had as 04 also and his did the same thing he said it was the hondamatic tranny was the prolbum with it causieng it to run hott.idk as long as it does not die on me ill be fine with it. for now
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top