Honda Foreman Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys I have an 01 rancher 350es 4x4. My problem is I can start it cold and ride it about a mile and it starts shutting down like it's hot. It will continue to idle if I let it but if I go to throttle it, it has no power and sometimes shuts completely down. It has a fan that is working with an oil cooler in front of it but the fan is not coming on this early in ride because I'm thinking the unit is not hot enough for the fan hence the reason I dont think it is overheating. I've cganged the oil and filter and made sure there is plenty of oil. I have replaced the cdi box and checked for loose connections and fuses. I'm totally stumped. Im thinking there is something telling the unit it's too hot and to shut down but I dont know what. Please help it's a great machine and I've put a lot of cash into this unit and it was running great and all of a sudden one day it started doing this.
 

·
Registered
Joined
·
163 Posts
Sounds like fuel flow issue
check fuel line for proper flow and clean filter in the tank and clean petcock passages
If you replaced CDI with cheap China made CDI from ebay its a waste of time, get a good used HONDA one on ebay
You need to determine if its not getting spark when it quits, or not getting fuel
 

·
Registered
Joined
·
4 Posts
sounds like it could be fuel related when it shuts down pull the air filter off and give it a shot of starting fluid and if it is idling but wont take a throttle hit it with a little starting fluid while trying the give it throttle and if it responds to it and tries to rev then i would definitely say its in the carb.
 
1 - 4 of 4 Posts
Top