Honda Foreman Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
501 Posts
I have the 3500X and I have only one problem and its my fault, I sorta broke the freespool knob
 

·
Registered
Joined
·
1,058 Posts
Just re-positioned my Venom 3500 from the top mount to the underside mount. This was because of the cable and roller fairland did not line up. The cable was rubbing on the steele plate. I have a different set up... I ordered the Aluminum Products bash plate that has the roller fairland positioned lower that stock. All alligned now...
 

·
Registered
Joined
·
459 Posts
I have the V2500XT and I like it, I have only had one problem with it too and it was my falt, had it at too much of an angle trying to pull my Foreman out of a mudhole and messed the cable up. It has pulled me out of alot of holes, it has been a good wench. I would recommend the V3000 or V3500 for these heavy Utility quads, just a little extra added power and insurance in the deepest of holes.
 

·
Registered
Joined
·
1,058 Posts
Did you have a problem with the " OUT " not working... Everything works great, except when I push the " OUT "..nothing happens. I think that it maybe the 2 bullet connectors.. ( Green and Black wires ). One is for the " IN " and one for the " OUT ". I think one is not making a connection. Don't know where to start. Brand new and never used except for the garage. Hmmmmm
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top