Honda Foreman Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So,I got a bike on trade got it running. Question is I can't keep it running unless I run full choke. I just had the carb rebuilt. They told me that a lobe on the cam was bad or the rings are bad. But I can't wrap my head around that to the fact that itll run change gears and do everything it's supposed to. No smoke, nothing modified, new electrical (stator, cdi,ecu). I've ruled out air lock. Any other recommendations? I will be pulling carb tomorrow to check needle and float and jets. I'm just at a loss.
 

·
Registered
Joined
·
714 Posts
first of all let us know what you have,year and model, hours and mileage helps,,,,did you empty the gas tank and make sure it has fresh gas and good flow, new plug, make sure exhaust is not plugged, check filters all the simple stuff first. i would do a compression test, it will tell you if cam or rings are bad, and yes check the carb.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
2004 Honda foreman 450es 3000 miles fresh gas new plug and filters. Petcock is clean new fuel lines. I havent done a compression test.
 

·
Registered
Joined
·
714 Posts
i am betting it is the float needle sticking, carb will need to be cleaned. I just went out to start my 2001 ruby today and it starts and runs for a few seconds and stalls, good gas flow,vfloat needle is sticking, time to pull the carb and clean it, after 17 years i bet there is lots of junk in my carb....time to get the lemon juice out....
 

·
Premium Member
Joined
·
2,041 Posts
X2.. who cleaned the carb? If you dont know them or seen it done right (taken apart and soaked in cleaner) they might have took it off and blown air thru it.. sounds like carb problem to me too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Replace carb seemed to fix the issue, it was the OEM carb. It is back firing at high rpms. Any fix for that. Seems to have alittle loss of power when first trying to get rolling. And I gotta take es gear motor of and re greases gears.
 

·
Registered
Joined
·
316 Posts
Did you replace the oem carb with another oem carb ? If not I’d re-rebuild the oem carb and go from there . I’ve heard of things in the aftermarket carbs not being completely drilled out or the jets not sitting in right causing lots of weird issues
 

·
Registered
Joined
·
228 Posts
Replace carb seemed to fix the issue, it was the OEM carb. It is back firing at high rpms. Any fix for that. Seems to have alittle loss of power when first trying to get rolling. And I gotta take es gear motor of and re greases gears.

My bike was doing that and I had to do a valve adjustment to get it to stop. Dont be scared to do it, with the service manual its a breeze.
 
1 - 8 of 8 Posts
Top