Honda Foreman Forums banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
I'll start out by admitting that I am not very mechanical.
I was plowng snow today with my 2001 Rubicon TRX500FA. I have NEVER had a problem with it, I couldn't ask for a better machine. Until today. In the middle of plowing I put the machine in reverse and it began to cut out (as if the choke was on when it was warm). I couldn't figure out what was wrong and after checking it out I noticed the gear selector indicator on the digital display was flashing D1, D2, and ESP all three at the same time. I spent several hours reading postings on here and other sites today trying to find out what this meant. The common thing seemed to be an Angel Sensor but everyone who had that problem had a specific number of flashes to indicate their problem. Mine just keeps flashing non stop. A friend of mine who is very good with working on most things came over and we took apart every wire harness that we could find, cleaned them and put diaelectric grease (or something like that) on them and put them back together with no luck. I have until tomorrow to get the problem fixed or be replaced on my plowing route. After not working for almost 3 months thanks to the crash in the real estate market I desperately need to get this figured out and fixed. I don't have time (or money) to take it in and get gouged by our local dealership that has become notoriously unethical in there service dept. in recent months. I would be very greatful for any advice anyone could give me.
Thank you
Travis
 

·
Registered
Joined
·
138 Posts
Well I would check your battery. If you were using the winch alot, perhaps the alt can't keep the battery changed. Clean the posts and have the battery chacked or even borrow another to eliminate that as the issue. Even just by disconnecting the battery may reset something electronic in your machine.
 

·
Registered
Joined
·
68 Posts
Mine was doing the same thing when the Throttle Position Sensor was acting up. Display flashing and when in reverse it would cut out.

Here is how to read your codes.

Put Bike in Neutral
Hold down the UP and DOWN ESP Button and Turn On Key
Release the 2 buttons
Press them again immediatley for 2 seconds.
The display should start flashing in a series.

Mine flashed 4 times for the TPS.

I don't have my manual on my work computer, so I can't tell you what the other codes are. Maybe somebody else here can.
 
G

·
Discussion Starter · #4 ·
Code flash

Thanks for the suggestions Putang59 and Il_Bow_Man. The battery test did not do anything but I was able to check the code with the instructions you gave me Bow Man. The code flash was 5 (I assume 5, it would flash quickly 5 times, pause, then flash 5 more times, then solid for a few seconds and then it would all repeat. Does anyone know what the code 5 is on a 2001 Rubicon TRX500FA? I am greatful for the help! By the way, I was able to get my route plowed. I rented a machine from my brother in law. Now I just need to get my machine going before the next snowfall. Thanks in advance to anyone who can tell me what the 5 code is.

Travis
 

·
Registered
Joined
·
9 Posts
CODE 5 - Angle Sensor System(motor lock)

According to the book it can be a loose connection: angle sensor, ECM, control motor.

Or you need to perform the initial setting procedure,

Or it could be a Faulty ECM, angle sensor, transmission unit, or ball nut is locked.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top