Honda Foreman Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,123 Posts
Discussion Starter · #1 ·
i got a epi clutch kit for my rubicon a while back. i was wondering if the kit made it harder to shift in esp. i have to push up or down about 3 times for it to shift. is this normal?
Thanks,Aaron
 

·
Registered
Joined
·
3,444 Posts
It should not affect shifting. Like Euro said, did you mess with the adjustment screw. I played with mine a bit and got it out of wack. but it was pretty easy to get it adjusted correctly again.
 

·
Registered
Joined
·
1,123 Posts
Discussion Starter · #4 ·
i dont think i ever messed with it. it will never hurt to look, how do you check it?
 

·
Registered
Joined
·
3,444 Posts
There is an adjust ment screw on the front cover you removed to install the clutch. It has a jam nut you must loosen. Then with a flat screw driver you can tighten and loosen the clutch.
 

·
Registered
Joined
·
1,123 Posts
Discussion Starter · #6 ·
so your saying its in the motor on the cover on the clutch? because im looking in my dads service book and all is says there is is the lock nut and thats all.
 

·
Registered
Joined
·
1,123 Posts
Discussion Starter · #8 ·
ok thanks i didnt think there was but i thought i was wrong thats why i looked it up in the service book. does anyone know what the problem is then? i know alot about hondas but i have only messed with clutches only a couple times and dont know much about them.
Thanks,Aaron
 

·
Registered
Joined
·
516 Posts
You might have some trash behind you buttons.
 

·
Registered
Joined
·
1,123 Posts
Discussion Starter · #10 ·
eustismudder i never thought of that and that may very well be whats wrong.
 
1 - 10 of 10 Posts
Top