Honda Foreman Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all-

I bought a TRX520 in the fall with the intention of plowing with it. I used it for the first two storms of the season with pretty good success, but on the third storm it stopped dead in the middle of the driveway. I figured it had frozen up so I pushed it down to the garage and let it sit overnight.

A day or two later it starts up fine so I take it out in the next storm. I run a few passes and boom, dead again. Back down to the garage and I let it sit. A week or two later it starts up fine again, this time with a bit of a backfire.

So I take it out in the next storm, a couple of passes in and it stalls out again. Won't restart. I push it back down to the garage again. But this time it doesn't restart at all.

Figuring that maybe I have bad gas, I drain the tank completely. New gas, some heet, but still nothing.

I pulled the fuel pump thinking I might find a clogged filter but then decided against disassembling it since it was all snapped together plastic. Still an option if you all think that's likely.

Any idea where to look? Common problems? Anything would be helpful.

Thanks!
 

·
Registered
Joined
·
459 Posts
I have heard there is a recall on fuel pumps, not sure if it includes the new ones, talk to your dealer see if there are any recalls on the fuel pump
 

·
Registered
Joined
·
91 Posts
Agree. That sounds a lot like a fuel pump issue, but I’d confirm that before throwing parts at it.
 
1 - 3 of 3 Posts
Top