Honda Foreman Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hello people,

I have a 06' foreman and when i reach top speed, my gear indicatro blinks 3 times a I have to stop the engine and start it again.
In the other day, it blinked 8 times?

What should I do?

Thks
 

·
Registered
Joined
·
56 Posts
3 times indicates problem with the angle sensor not sure about the 8 flashes though. I replaced my angle sensor a couple weeks ago and got to really try it out this past weekend. No problems at all, nice smooth shifting, so hopefully I've got it fixed for good, or atleast for a while.

If you dont want to dish out the $40 for a new sensor at least try taking it off cleaning it up a little and reinstalling it coating it in di-electric grease to try to keep out the water/mud.
 

·
Registered
Joined
·
56 Posts
3 times indicates problem with the angle sensor not sure about the 8 flashes though. I replaced my angle sensor a couple weeks ago and got to really try it out this past weekend. No problems at all, nice smooth shifting, so hopefully I've got it fixed for good, or atleast for a while.

If you dont want to dish out the $40 for a new sensor at least try taking it off cleaning it up a little and reinstalling it coating it in di-electric grease to try to keep out the water/mud.
 

·
Registered
Joined
·
56 Posts
3 times indicates problem with the angle sensor not sure about the 8 flashes though. I replaced my angle sensor a couple weeks ago and got to really try it out this past weekend. No problems at all, nice smooth shifting, so hopefully I've got it fixed for good, or atleast for a while.

If you dont want to dish out the $40 for a new sensor at least try taking it off cleaning it up a little and reinstalling it coating it in di-electric grease to try to keep out the water/mud.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top