Honda Foreman Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Just to get this posted in here and documented for the future, I have a 2007 Rubicon Automatic I just bought that has this issue. (Also is currently only front wheel drive as something is messed up in the rear drive-line, but I haven't even tried to see if it is the driveshaft, u-joint, rear axle, rear diff or some combination of these.) I'm focusing on the shifting for starters. If the Hondamatic unit turns out to be bad, I don't want any more money in it. The carb had been replaced by the previous owner, so I suspected it needed a Reset/Initial Setting Procedure (I'll call this ISP to save typing!) performed.

It was flashing D1,D2, ESP when I bought it. Starts great, runs great, changes R,N,D great, but won't change into a higher gear when riding (in 4x4 as a front wheel drive). Stays in first gear.
I'm almost positive it was flashing Code 11 'ECM Motor Drive Circuit', but can't validate that now. You'll see why in a minute.

So, here is what I did.
1. Pulled ES motor to validate it was good. Test showed it to be good.
2. Replaced Angle Sensor. Cheap and easy, so I did it. (Of course now it's flashing Code 6 'Angle Sensor', but only Code 6. Code 11 appears to be gone.)
3. Cleaned all the associated connectors at this end, but not at the ECU yet.
4. Attempted to perform the Reset/ISP

The ISP fails miserably. There is no discernable change in what is happening. It's like I'm not even pushing the Up/Down buttons.
 

·
Premium Member
Joined
·
13,184 Posts
You used the word "cheap" with the angle sensor so that tells me you used and aftermarket sensor and not OEM. That would be the first problem to fix.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
You used the word "cheap" with the angle sensor so that tells me you used and aftermarket sensor and not OEM. That would be the first problem to fix.
OK. I wasn't aware that the aftermarket ones had issues. My Honda branded Angle Sensor is on the way and is guaranteed to be here by 12/31. In the meantime, is there anything else I can check on?
 

·
Registered
Joined
·
14 Posts
Just to get this posted in here and documented for the future, I have a 2007 Rubicon Automatic I just bought that has this issue. (Also is currently only front wheel drive as something is messed up in the rear drive-line, but I haven't even tried to see if it is the driveshaft, u-joint, rear axle, rear diff or some combination of these.) I'm focusing on the shifting for starters. If the Hondamatic unit turns out to be bad, I don't want any more money in it. The carb had been replaced by the previous owner, so I suspected it needed a Reset/Initial Setting Procedure (I'll call this ISP to save typing!) performed.

It was flashing D1,D2, ESP when I bought it. Starts great, runs great, changes R,N,D great, but won't change into a higher gear when riding (in 4x4 as a front wheel drive). Stays in first gear.
I'm almost positive it was flashing Code 11 'ECM Motor Drive Circuit', but can't validate that now. You'll see why in a minute.

So, here is what I did.
1. Pulled ES motor to validate it was good. Test showed it to be good.
2. Replaced Angle Sensor. Cheap and easy, so I did it. (Of course now it's flashing Code 6 'Angle Sensor', but only Code 6. Code 11 appears to be gone.)
3. Cleaned all the associated connectors at this end, but not at the ECU yet.
4. Attempted to perform the Reset/ISP

The ISP fails miserably. There is no discernable change in what is happening. It's like I'm not even pushing the Up/Down buttons.
Yes disconnect the battery when changing parts after the parts are changed connect the battery and clear the faults before you try to start your unit. I went through the same problem and found out that not all new parts are going to work right and you may need to order the same part twice , I go have a post with the same problems I ended up going to a after market shift motor that solved my code 6 and the part tome code 11 problem . The shift motor is by Venom by seller jetskiplusllc.com got it on amazon.
 
1 - 4 of 4 Posts
Top