Honda Foreman Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
3,177 Posts
Discussion Starter #1
Anyone here have the Highlifter lift kit? I got a few questions.
 

·
Registered
Joined
·
100 Posts
i dont, but, i did help my buddy install one on his honda tho...fire away with the questions, i'll give you the best answers i can.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #3
After installing the front, my axles are not looking happy. If jack the bike up and let the suspension droop, I cant even turn the wheels over with out the axles binding up. When its sittin on the ground, the axles just look wrong, they are at a pretty bad looking angle Is this normal?
 

·
Registered
Joined
·
100 Posts
QUOTE ("Robb":2vsw49je)
After installing the front, my axles are not looking happy. If jack the bike up and let the suspension droop, I cant even turn the wheels over with out the axles binding up. When its sittin on the ground, the axles just look wrong, they are at a pretty bad looking angle Is this normal?
hm... that doesnt sound to good now does it?...when you spin them do you hear a clicking noise or anything? or could your cv's possibly be worn out from prior hard use?i have the perfex kit on mine and the cv's are noticably at more of an angle..but i dont have any binding....even at full droop...i have heard that the highlifter kit isnt exactly the best route to go
for a lift because 2 inches is a bit to much for the foreman axles...but then again i have heard that it isnt to much....with out seeing your set-up and mesisng with it i cant really tell you for sure 1 way or the other..but regardless or normal or not i would definately say it is not good.
 

·
Registered
Joined
·
3,444 Posts
Robb, that doen't sound good. I would not run it like that. Maybe you could just use the rear lift, and not use the front.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #6
yeah there is no way im gonna run it like this...I talked to HL today, and they want some digital pics - so im gonna do that at lunch time. Curious to hear what they say.
 

·
Registered
Joined
·
3,444 Posts
They say they are really good with customers satisfaction, I'm sure they will take care of you.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #8
this is one of the pics I sent them, this is with the bike sitting on the ground.
 

·
Registered
Joined
·
3,444 Posts
You did not pull the drive shaft out right? It looks like the cv joint is seperated on top. It sure doesn't look healthy.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #11
yeah see thats what i thought too...so I pulled the axle off the bike, and it was fine, put it back in, and it does that. I dont get it.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #12
BTW thanks Jeff!
 

·
Registered
Joined
·
1,994 Posts
Wow now that dosent look right at all i am sure they will help ya after seeing a pic like that.
 

·
Registered
Joined
·
1,215 Posts
I have a 2" Hi Lifter lift on my 04' Foreman. I'm posting a few pics. No problems here.... But maybe you can compare...
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #15
Hmm, installed jus like mine..maybe my axle is just messed up. Thanks.
 

·
Registered
Joined
·
1,215 Posts
Yeah, I can get some more pictures, but not til after about 6:00 this evening.
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #18
Well I took mine off today after the response I got from Highlifter
QUOTE
From Highlifter - I got the pictures and forwarded them on to our research guys. From what I saw and what they told me everything looked to be installed correctly. We have sold thousands of the kits over the years and never had a problem like this. My recommendation would be; If you think that the lift will harm your machine, remove it. We can not refund your money because the kit has been installed.
I dont know, figures I got a freak bike that wont let me lift it. Anyone have any ideas, my axles must be screwy or something. With out the lift kit everything sits fun, axles look good, so im at a real loss.
 

·
Registered
Joined
·
1,994 Posts
Well robb lets try just the front part of the kit on my bike to see if it does the same thing
 

·
Registered
Joined
·
3,177 Posts
Discussion Starter #20
no problem...its pretty easy to throw on, im sure it will be fine in yours.
 
1 - 20 of 38 Posts
Top