Honda Foreman Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello everyone, Im new here and was really hoping someone could help me figure out what is going on with my machine. It is a 99 honda foreman 450 es with 1400 miles. first let me say that since my issues started I changed the oil, and put a brand new battery in it. So here it goes, start up the machine in neutral, shift into first a 1 appears on my readout and i drive along, speedo is not working, just reads 0. I can shift right through all gears fine as long as im not hard on the throttle, if i baby it all is well, if im getting on it, no matter what gear im in my gear number on my readout turns into two lines like this -- and i am now stuck in that gear, cant down shift or upshift, BUT... if i just roll to a stop, turn off the machine with the key, turn the key back on, the gear position read out now works fine, i shift to neutral, start up and move along again, the whole time with a speedo that reads 0. I went on a very frustrating 10 mile ride with a buddy yesterday and this drove me nuts!!! On the way out I just babied it and kept it below half throttle and got out with no issues, shifted through all gears just fine. PLEASE tell me somebody knows what the heck this is??? Thanks in advance.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Still puzzled.......

Cant believe that out of 77 people who viewed this post not one response... Still trying to figure out whats going on, angle sensor???
 

·
Registered
Joined
·
74 Posts
Try the manual clutch adjustment for the shifting, these tend to seize up. Easy fix but you have to pull the front case off the engine. Your dash is getting power, so check the sensors, could be a dirty connection, or just gone bad.
 

·
Premium Member
Joined
·
13,198 Posts
You need to test the speed sensor to see if that is the problem or if it is in the wiring, meter or ECM. That is most likely giving the problems since the ECM uses readings from that to help determine shift points. When you shut off the key you are resetting the ECM
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks Toodeep, I appreciate that. You have to forgive me, Im not much of a mechanic... I rode old Honda machines my whole life that didnt have much to do with electronics and what not. I feel stupid asking, but if you wouldnt mind, and you have the time, could you please give me a bit more specifics? Your diagnosis makes sense to me. Thank you very much.
 
1 - 8 of 8 Posts
Top