Honda Foreman Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,464 Posts
Discussion Starter #1
Does anyone have any idea on why the 420 would go to running rich? My snorkel has been on it long before this ever started, I changed oil and plug a while back and it started smoking a little immediatley after, well was on my little suzuki following my dad on the 420 and noticed the smoke is black and i can smell raw gas at the exhaust.. Im not inclined enough about efi/valves to dig in it myself. Think im gonna pick up a new plug tommorow just for the **** of it. I havent had time to pull the plug but since it sat up for two weeks while i was building the rack/winch it has gotten horrible about smoking black smoke. Any suggestion?:rant
 

·
Registered
Joined
·
3,488 Posts
dont hink theres much you can do is its EFI. black smoke out the exhaust usually means choke is stuck open but not sure on those new EFI machines might be a dealer trip
 

·
Registered
Joined
·
1,723 Posts
That's sucks. My bike started running lean since the colder weather hit.
 

·
Registered
Joined
·
115 Posts
Id try disconnecting the negative lead of the battery for about 20 mins. this will reset the computer so when you crank it up again it will re-adjust. if that doesn't help it i have heard of leaking injectors but i wouldn't think thats it since its a 2012. hows the air filter look?
 

·
Registered
Joined
·
1,464 Posts
Discussion Starter #5
Id try disconnecting the negative lead of the battery for about 20 mins. this will reset the computer so when you crank it up again it will re-adjust. if that doesn't help it i have heard of leaking injectors but i wouldn't think thats it since its a 2012. hows the air filter look?
Will keep it in mind, might actually leave it unhooked over night. Ive heard of computers on vehicles needing reset via this method before. Air filter is original but I keep it clean. Im picking a new plug and filter up tomorrow just to try it.
 

·
Registered
Joined
·
115 Posts
did you fix your smoking problem that you had a while back?
 

·
Premium Member
Joined
·
1,048 Posts
might be a stupid question and dont be insulted but did you put the oil filter in backwords?
 

·
Premium Member
Joined
·
7,535 Posts
wanna follow...and your saying it's too rich ....correct?
 

·
Registered
Joined
·
1,464 Posts
Discussion Starter #9
did you fix your smoking problem that you had a while back?
No same problem, I noticed it smoking slightly but then realized its not oil smoke (i was thinking rings) but its definatly fuel smoke

might be a stupid question and dont be insulted but did you put the oil filter in backwords?
lol no offense taken, ive seen it happen. But no its in correct, it wouldve done blown by now.

wanna follow...and your saying it's too rich ....correct?
Yea its leaving a black smut on the exhaust tip,can smell raw gas out the exhaust when you throttle up.
 

·
Premium Member
Joined
·
1,048 Posts
id try the battery cable and see what happens. you could take the air box lid off and see if you can get some more air in the mixture to see if it will run less rich. just an idea im stumped, if all else fails take it to a dealer
 

·
Registered
Joined
·
1,464 Posts
Discussion Starter #12
I was off work yesterday, So i changed the Oil & filter, Spark Plug and Air filter and the whole time i was changing all that i had the terminals off. I've still got a little smoke (oil smoke) but the black sutty smoke is gone. Im thinking with a dirty filter it wasnt getting enough air through. Im still concerned though, If i rev it up (not tapping rev just increase rpms) in neutral it pops a bit when you let off. Not sure if that means anything or not..
 

·
Premium Member
Joined
·
1,048 Posts
which filter was dirty? your air filter?
 

·
Registered
Joined
·
1,464 Posts
Discussion Starter #14
yea the air filter was, Ive noticed the last two oil changes on my 420 the fins on the oil filter are always spread apart/bent. Im not sure whats causing it, the filter is in correct. The foreman we done yesterday doesnt have this problem.
 

·
Premium Member
Joined
·
1,048 Posts
there wouldnt be anything restricting air flow in your stock snorkel would there? dust build up or something?
 

·
Registered
Joined
·
1 Posts
Honda rancher fuel air mixture problem??? HELP!!!!

Have you figured out the problem. I'm having the same problem with my 2007 Honda rancher 420 FI 4wd foot shift
 

·
Registered
Joined
·
5 Posts
does th bike run high idle? if so look on the carburetor, and check the throttle body it can may b up to high, and see if u can turn it down!
 
1 - 19 of 19 Posts
Top