Honda Foreman Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello everyone,
I have a 2018 Honda Rubicon deluxe and just did an oil change on it with Honda oil and filter. Went out riding yesterday and noticed it was shifting kind of hard (drive gears) and then went to put it into reverse and experienced a delayed response. I have to kind rev it up to a certain rpm before it will actually move in reverse. It shows "R" on my dashboard when I shift into reverse but it just doesn't move until I get to that higher rpm with the throttle. I'm baffled, It was working fine before I did an oil change and I used the Honda GN4 oil and filter straight from a Honda dealership. Has anyone ever experienced this before? Help!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
Hello everyone,
I have a 2018 Honda Rubicon deluxe and just did an oil change on it with Honda oil and filter. Went out riding yesterday and noticed it was shifting kind of hard (drive gears) and then went to put it into reverse and experienced a delayed response. I have to kind rev it up to a certain rpm before it will actually move in reverse. It shows "R" on my dashboard when I shift into reverse but it just doesn't move until I get to that higher rpm with the throttle. I'm baffled, It was working fine before I did an oil change and I used the Honda GN4 oil and filter straight from a Honda dealership. Has anyone ever experienced this before? Help!
Does anyone know if this might be a clutch adjustment problem?
 
1 - 3 of 3 Posts
Top