Honda Foreman Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys. I have a 2007 Rubicon. I purchased this bike a while back, and got it running. However, I immediately noticed that I am setting codes on the screen, as well as the fact that the bike is not shifting (stuck in low gear, unable to see gear due to indicator flashing). I have the Honda manual and have been through the steps- all of them. Majority of the time I am setting code 13- mode select switch circuit malfunction. Sometimes when I turn the key to the ON position, I receive code 7 instead- ESP shift switch circuit malfunction. I have already determined that the mode select switch is good, checked and cleaned switch, also replaced with NIB switch. What I have figured out is that the shift switches are good- have cleaned, tested, and purchased a used set and checked those- no issue. The MAIN PROBLEM I am facing , is that the input from the shift buttons are not being received by the computer- have also purchased used 07 computer- no difference. I cannot clear/erase codes, or make it do anything other than continually blink! From what I have diagnosed, I have some sort of wiring issue (shift switches not making connection to computer). I am no professional at electrical issues, but after sitting for a while and looking through the wiring diagram, I am searching for the JC1/JC2 area of the harness to continue tracking down the bl/r wire for the shift switches. Does anyone know where on the bike (connector) or in the harness JC1/JC2 is? Or does anyone have any other suggestions? Please let me know. Thanks!
 
1 - 1 of 1 Posts
Top