Honda Foreman Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
while riding in West Virginia the brakes on the rancher started locking up, there is no feathering the brake handle if you squeeze the handle, even a little the brakes lock so quick and tight if you are on gravel you'll just slide and if on pavement you'll flip over the front. It's just unsafe. had this ever happend to anyone. Or are there any idea's on what could cause this?
 

·
Registered
Joined
·
12 Posts
I had a similar problem on a 1981 Honda 70 ATC, when I took the brakes apart to see why this was happening the brake shoe pad had started to separate from the shoe base and was causing it to bind, I guess water got into the brakes and it could not get out because the drain was clogged with mud and it loosened the glue that holds the shoe pad to the shoe base....be prepared for a bit of a battle to get the drum off.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #3 ·
Sounds like fun, I took it to the dealer today to see what they could do. I was going to see what I could find out but it was due for its second service anyway and the valves are ticking. So I guess I'll wait and see what they say. I told them that the brakes were locking up and when they went to test drive it he hit the brakes and almost flipped over the handle bars, you should have seen his face when that happened. He almost crapped himself. I just hope it's covered by the warranty.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #5 ·
Yeah I got it back from the dealer today, there was a very small amount of sand (they said a couple a grains actually) that got in there, they cleaned it out and now it works perfectly, not covered by the warranty though, that plus a valve adjustment it cost $230. A little pricey, but It's better than killing myself going down a hill when I hit the brakes.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #7 ·
QUOTE ("Eric":2llff892)
$230..........


ouch
yeah you said it, I think is was 75/hr labor, they charged me to tear the brakes apart, clean and bleed. Plus an hour and a half to adjust the valves. By the way the valves were off adjustment by double, no wonder the motor had a ticking noise. I guess driving at 56 mph for at least 5-10 miles at a time will do that.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top