Honda Foreman Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Looking to see if there are any circuit board wizards on here to help with my es combination meter.I have found a replacement 37200-HN0-771 but having a hard time spending$400 before trying to repair the one I have.
The story is this…
I got the machine used with the display cover crack with visible moisture inside. Display worked with everything visible. Upon replacing the cover, I decided to blow the circuit board off to remove the remaining moisture but in doing so a small piece came off. Now the display half works and displays mostly “L” instead a full 0’s for mph and mileage. The circuit board does show signs of corrosion but was working prior to me being an idiot.
Any ideas would be greatly appreciated!
 

· Registered
Joined
·
2 Posts
Looking to see if there are any circuit board wizards on here to help with my es combination meter.I have found a replacement 37200-HN0-771 but having a hard time spending$400 before trying to repair the one I have.
The story is this…
I got the machine used with the display cover crack with visible moisture inside. Display worked with everything visible. Upon replacing the cover, I decided to blow the circuit board off to remove the remaining moisture but in doing so a small piece came off. Now the display half works and displays mostly “L” instead a full 0’s for mph and mileage. The circuit board does show signs of corrosion but was working prior to me being an idiot.
Any ideas would be greatly appreciated!
Do you still have that new combination meter or do you know where I can get one? The - HNO- 771 one.
 
1 - 5 of 5 Posts
Top