Honda Foreman Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
The other day I went to get my quad out and found oil under it on the floor. After pulling the skid plate and cleaning up a bit, I found the manual shift rod seal had backed out a little and leaked. I pushed it back in and will replace if it does it again. Has anyone else had this happen ?

I also found a wire unplugged after I removed the skid plate. I cleaned it up and reattatched it. It's on the bottom of the crankcase. Is this the oil light sensor ?
 

·
Registered
Joined
·
10 Posts
leaky shifter seal

Yeah I have a 2000 honda 450S with 9196 miles on it. It has happened a couple of times. I fixed it with red lock tite. Next time you do an oil change drain the oil out. Then pop the seal out, clean out the hole and seal with brake clean, spread red lock tite on the seal and it the hole with a small brush, push the seal back in and let it set over nite. Next day fill and have fun!!
 

·
Registered
Joined
·
3,177 Posts
thats a lot of miles
 

·
Premium Member
Joined
·
3,440 Posts
Makes me proud to be a Honda Foreman owner with those kind of miles.
 

·
Registered
Joined
·
1,994 Posts
wish i had that many miles with no problems. BUt i just get a million problems with very little miles.
 

·
Premium Member
Joined
·
3,440 Posts
QUOTE ("Rubicon3303":2134v7r5)
wish i had that many miles with no problems. BUt i just get a million problems with very little miles.
Travis, you must have gotten a lemon. My buddy has a Rubicon that is
a couple of years old & beats the livin' crap out of it & no problems.
Hope things start goin' your way when you get it back.
 
1 - 7 of 7 Posts
Top