Honda Foreman Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I recently bought an 02 foreman S for dirt cheap with a broken shifter. I put it in the shop and had the shifter repaired and while they were in there I had them install an EPI clutch kit. I was unable to drive it before putting it in the shop so i have no baseline. Just wondering is it normal for the engine to heat up kinda quickly or could this be from the higher stall from the kit and higher rpm? Also is the foreman sort of hard to steer even in 2WD? I got it out of the shop yesterday and added some floorboards and stick stoppers then drove it around tonight just up and down the street. I had a little trouble at first shifting but then it operated smoothly after a few shifts and driving it for a minute. Is it possible that the shifting will be kind of sticky due to the stiffer clutch springs from the kit..maybe until i ride it a little more? and are they known for being noisy and making a knocking sound on start up? The bike only has 400 miles on it and fires right up, its just noisy sounding --> this may sound stupid but its noticeably different from my other atvs on start up. I know its a lot of questions at once but i want to make sure everything is running as it should. Thanks for any input.
 

·
Premium Member
Joined
·
17,868 Posts
it is a air cooled motor mine allways runs a little warm
you may want to jack up the front end and turn it left then right see if its still tight (frozzen ball joints)
mine makes the same noise when it is cold .it goes away when warm no problems so far good luck ...RICH
 

·
Registered
02 450 honda s
Joined
·
6 Posts
Hello new here i have a 02 foremans s and was riding it down over street and heard a loud bang it died and now I have no spark can not start withe the starter or by the pull cord anyone have any ideas what happened
 
1 - 4 of 4 Posts
Top