New an need help - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-31-2019, 07:22 PM Thread Starter
Honda Rider
 
Join Date: May 2019
Posts: 3
New an need help

Just got a 2003 Honda Rubicon 500 and it flashes d1 d2 and esp it worked the 1st night it was home with me and the next day for 2 hours then it wouldnt work in esp just start flashing all 3 d1 d2 an esp so i shut it off an did started it in d1 and it ran fine same with d2 but today i start it an it just flashes all 3 once again. Please help is it my angle sensor??
Cody Benson is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-31-2019, 08:28 PM
Honda Red Wing Rider
 
mrbb's Avatar
 
Join Date: Jul 2012
Location: ne PA
Posts: 3,311
I'd start with getting yourself a service manual!

will tell you what codes flashing mean and to check!
there should be free down loads for manuals if you search here!
mrbb is offline  
post #3 of 6 (permalink) Old 05-31-2019, 08:31 PM
Honda Addict
 
Join Date: Nov 2018
Location: South Texas
Posts: 216
Here's a link to the SM to make it easy........

https://drive.google.com/drive/folde...7LP-eZp2jMRVJU

2007 Foreman 500FM
2014 Foreman 500FM
Service Manuals Link: https://drive.google.com/drive/folde...7LP-eZp2jMRVJU
Wilbur is offline  
 
post #4 of 6 (permalink) Old 05-31-2019, 11:04 PM Thread Starter
Honda Rider
 
Join Date: May 2019
Posts: 3
So the only thing im not getting is the code thing. It shows d1 d2 esp for 3 seconds an flashes it 5 times after. Would that be like a code 5 or something?
Cody Benson is offline  
post #5 of 6 (permalink) Old 07-11-2019, 03:48 AM
Honda Rider
 
Join Date: Jul 2019
Posts: 6
Wow many many congrats dear.
lucyjohn987 is offline  
post #6 of 6 (permalink) Old 07-11-2019, 10:46 AM
Honda Red Wing Rider
 
jeepwm69's Avatar
 
Join Date: Nov 2009
Posts: 6,099
Garage
Quote:
Originally Posted by Cody Benson View Post
So the only thing im not getting is the code thing. It shows d1 d2 esp for 3 seconds an flashes it 5 times after. Would that be like a code 5 or something?
Sounds like it.


First thing you need to do on a Rubicon is make sure you have a good, fully charged battery with clean cable ends.


Download a service manual here.


https://drive.google.com/drive/folde...7LP-eZp2jMRVJU


Look under the transmission section for your machine, and it will give you error code diagnosis and troubleshooting instructions.

2005 Foreman Rubicon Camo
Perfex, 27" Mudbugs
Heated grips and Thumb , HID's
5K Viper Max winch

2009 Foreman 500FM Green
Perfex with HL springs
27" Execs on Rubicon rims
Heated Grips and Thumb, HID's
4K Viper Max winch

2006 Foreman 500FM Green
28" Mugbugs, stretched, Perfex, HLsprings
3K Superwinch winch

2009 475 Rancher AT Tan
26" Mudbugs on Rincon rims
Warn winch. Foreman pod light with HID, SRA gear reduction
jeepwm69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome