2008 trx420fe running issue - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-15-2019, 04:59 AM Thread Starter
Honda Rider
 
Join Date: Aug 2015
Posts: 1
2008 trx420fe running issue

have 2008 trx420fe and it's cutting off when turning left. I removed front rack and fender and turning left issue stopped but now would cut out driving straight. inspection of harness found that when grabbing harness below right side of handlebars the ATV would cut off or more specifically the Brown power wire to fuel pump would lose power. tracing Brown wire back into main harness found spot that wire felt/seemed broken. repaired wire and plugged all wires back up and now won't even turn over or power fuel pump. at fuel/engine start relay I have power on 2 black/gréen wires? assume it's lacking signal to make relay transmit power to start circuit and fuel pump. any ideas or insight would be appreciated.

thanks

and had similar issue 12-15 ago that required a new wiring harness to repair. hope doesn't require anouther harness. my trusty 99 trx300fwd never has the issues that this 420 has fairly regularly. simple is better sometimes.
Lap4768 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome