04 Rubicon 500 D2 - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-11-2015, 10:52 PM Thread Starter
Honda Rider
 
Join Date: Dec 2015
Posts: 3
04 Rubicon 500 D2

Hey I have a problem with my Rubicon in D2. It will move and run in D2 but it doesn't move until you give plenty of throttle and then the machine acts like it is under a strain but will go. The rest D1 and ESP works fine. Even reverse works fine. Does anybody know what's causing this problem
Britt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
02 Rubicon 500 d1 d2 esp flash Striker Rubicon 500 29 02-27-2014 08:12 AM
04 Rubi, trouble getting in drive in D2 Duckhunter14 Rubicon 500 7 03-23-2012 08:31 PM
01 Rubicon stuck in 5th D1 D2 ESP shows lorolytle Rubicon 500 0 08-28-2009 07:31 PM
D1/D2 ESP Light Flashing 03 Rubicon mcole50 Rubicon 500 2 02-29-2008 06:39 AM
D1 or D2???? And also a ? on first Valve adjust 2007 Rubicon MACH Rubicon 500 7 12-21-2007 09:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome