2013 Foreman Fuel Pump Help Please - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 04-12-2019, 06:41 PM Thread Starter
Honda Rider
 
Join Date: Apr 2019
Posts: 4
2013 Foreman Fuel Pump Help Please

I have a 2013 foreman with a fuel pump issue I can't figure out. Had a mouse build a nest behind the battery and chew the wires on the sub-harness that goes to the fuel pump relay. It would still run but I still replaced the sub-harness. The problem I'm having is when you turn the ignition on without starting it the fuel pump will pressurize but not shut off. It just keeps running. Before the mouse decided to take up residence the fuel pump would pressurize then click and shut off. I tried replacing the fuel pump relay but that didn't help either. I've checked all the other wiring and everything else looks good. I just can't figure out what's going on with it. Any help would be greatly appreciated.
frankie69 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-14-2019, 06:51 AM Thread Starter
Honda Rider
 
Join Date: Apr 2019
Posts: 4
Still trying to figure this one out. Surely someone has some ideas. Help me out please if you can. Thanks.
frankie69 is offline  
post #3 of 6 (permalink) Old 04-14-2019, 09:36 AM
Honda Lover
 
Join Date: Jul 2018
Location: WV
Posts: 255
I think the pressure cutoff is in the pump itself, but I would have to study the wiring diagram for the 2013 to say for sure.



No fuel leaks? Injector leaking?
Moccasin Ranger is offline  
 
post #4 of 6 (permalink) Old 04-14-2019, 10:02 AM Thread Starter
Honda Rider
 
Join Date: Apr 2019
Posts: 4
Thanks for replying. No leaks anywhere. This bike is very lightly used and in really good condition. I'm 50 years old and bought it new for hunting purposes so it's lead a very gentle life until the mouse issue. It runs fine just like it always has other than the fuel pump not shutting off once it reaches pressure. I've parked it and started using my wife's Recon right now (turkey season) until I can get this sorted out. I just don't want to have to take it to the dealer if it's something simple. I welcome any thoughts on this. Thanks.
frankie69 is offline  
post #5 of 6 (permalink) Old 04-14-2019, 11:46 AM
Honda Lover
 
Join Date: Jul 2018
Location: WV
Posts: 255
Does it show any sign of running rich? Black smoke or a sooty spark plug? Gassy smell in the oil? That could be a leaky injector.



Many electric pumps do have the pressure cutoff built into the pump, I'm just not sure about the 2013.
Moccasin Ranger is offline  
post #6 of 6 (permalink) Old 04-14-2019, 12:15 PM Thread Starter
Honda Rider
 
Join Date: Apr 2019
Posts: 4
No smoke and nothing rich. Oil is clean with no gassy smell. Spark plug is clean. I wondered about the shut off being in the pump. Maybe it shorted to on when I tried to start it initially before I noticed the mouse had chewed sub-harness? This machine has the external pump not the type made into the fuel tank.
frankie69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 Honda Foreman 350-no spark and fuel pump wiberforce Vintage Honda 1 01-29-2018 11:02 AM
1984 foreman FUEL PUMP😡 PETCHU Foreman 400 0 07-16-2016 09:37 AM
Fuel pump out on 2012 foreman shiyfire Foreman 500 2 03-08-2014 06:20 PM
07 foreman fuel filter and pump location twilson12 Foreman 500 12 09-22-2012 06:59 PM
Fuel pump? 2thamax Rubicon 500 4 07-12-2009 03:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome