Help 02 Forman 500 voltage regulator problem? - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old Yesterday, 04:39 PM Thread Starter
Honda Rider
 
Join Date: Oct 2018
Posts: 8
Help 02 Forman 500 voltage regulator problem?

Hello everyone. My Forman runs with the voltage regulator unbolted from the frame. Mount it and won’t hit at all. When it’s running the regulator gets hot. Any ideas would be appreciated.
302dz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Yesterday, 04:40 PM
Honda Red Wing Rider
 
jeepwm69's Avatar
 
Join Date: Nov 2009
Posts: 5,946
Garage
Rubicon? There was no Foreman 500 in 2002.

2009 Foreman 500FM Green
27" Execs on Rubicon rims, Perfex
Heated grips and Thumb , HID's
5K Viper Max winch

2009 Foreman 500FM Green
Perfex with HL springs
27" Mudbugs on Rubicon rims
Heated Grips and Thumb, HID's
4K Viper Max winch

2006 Foreman 500FM Green
28" Mugbugs, stretched, Perfex, HLsprings
3K Superwinch winch

2009 475 Rancher AT Tan
26" Mudbugs on Rincon rims
Warn winch. Foreman pod light with HID, SRA gear reduction
jeepwm69 is offline  
post #3 of 6 (permalink) Old Yesterday, 04:50 PM Thread Starter
Honda Rider
 
Join Date: Oct 2018
Posts: 8
Sorry it has Honda Forman S on the tank maybe 450?
302dz is offline  
 
post #4 of 6 (permalink) Old Yesterday, 08:35 PM
Administrator
 
toodeep's Avatar
 
Join Date: Aug 2007
Location: south dakota
Posts: 12,906
Garage
450. I would guess the regulator is bad. They are very common to short out.and melt the plug or give a no fire situation (ign spark).

Sent from my SM-G965U using Tapatalk



2007 420FM (475cc, 27x12x12 Mudbugs) ---------- 1995 300FW (webcamshaft, 350 rear end)
2008 420FE (26x9x12 BearClaws) -------------------
1988 300 (old stock machine, nothing fancy)
2009 420FA (25x8/10x12 BearClaw HTR) ---------
1987 350D (work in progress)

toodeep is offline  
post #5 of 6 (permalink) Old Today, 06:04 AM Thread Starter
Honda Rider
 
Join Date: Oct 2018
Posts: 8
Many thanks. I’ll try that. Do aftermarkets work or do I need OEM?
302dz is offline  
post #6 of 6 (permalink) Old Today, 11:34 AM
Administrator
 
toodeep's Avatar
 
Join Date: Aug 2007
Location: south dakota
Posts: 12,906
Garage
I've only used OEM.

Sent from my SM-G965U using Tapatalk



2007 420FM (475cc, 27x12x12 Mudbugs) ---------- 1995 300FW (webcamshaft, 350 rear end)
2008 420FE (26x9x12 BearClaws) -------------------
1988 300 (old stock machine, nothing fancy)
2009 420FA (25x8/10x12 BearClaw HTR) ---------
1987 350D (work in progress)

toodeep is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rectifier/voltage Regulator Jbp1988 Foreman 500 5 04-01-2013 09:24 PM
Voltage Regulator MacNicol Racing Foreman 450 2 12-28-2010 03:20 PM
450 es voltage regulator 300winchester Foreman 450 4 08-07-2009 09:13 AM
Voltage Regulator JFK19 Foreman 450 1 04-23-2009 03:11 PM
bad Voltage regulator foreman 4 men Foreman 400 2 04-14-2009 09:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome