650 Rincon Transmission Slipping - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 01-20-2010, 12:05 PM Thread Starter
Honda Rider
 
Join Date: Jul 2009
Location: Gilmer, TX
Posts: 23
Send a message via AIM to dustyt07
Need help diagnosing a problem with a 2003 Honda Rincon 650 with a slipping problem in the transmission? Has anyone had this problem before?
Tried changing oil and help for a little bit but went back to slipping again.
dustyt07 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-20-2010, 12:18 PM
Administrator
 
toodeep's Avatar
 
Join Date: Aug 2007
Location: south dakota
Posts: 11,358
Garage
Make sure it's slightly overfilled with oil. Has the oil pump o-rings ever been replaced? 03 had a problem with them.



2007 420FM (475cc, 27x12x12 Mudbugs) ---------- 1995 300FW (webcamshaft, 350 rear end)
2008 420FE (26x9x12 BearClaws) -------------------
1988 300 (old stock machine, nothing fancy)
2009 420FA (25x8/10x12 BearClaw HTR) ---------
1987 350D (work in progress)

toodeep is offline  
post #3 of 5 (permalink) Old 01-20-2010, 05:04 PM Thread Starter
Honda Rider
 
Join Date: Jul 2009
Location: Gilmer, TX
Posts: 23
Send a message via AIM to dustyt07
ill check the oil and the o rings have not been replaced. how can that be done?
dustyt07 is offline  
post #4 of 5 (permalink) Old 01-20-2010, 05:07 PM
Administrator
 
toodeep's Avatar
 
Join Date: Aug 2007
Location: south dakota
Posts: 11,358
Garage
The front engine cover and oil pump have to be removed and the o-rings are behind the oil pump.

#13 : http://partsfinder.onlinemicrofiche.com/ho...;A=168&B=15



2007 420FM (475cc, 27x12x12 Mudbugs) ---------- 1995 300FW (webcamshaft, 350 rear end)
2008 420FE (26x9x12 BearClaws) -------------------
1988 300 (old stock machine, nothing fancy)
2009 420FA (25x8/10x12 BearClaw HTR) ---------
1987 350D (work in progress)

toodeep is offline  
post #5 of 5 (permalink) Old 01-31-2010, 09:26 PM
Honda Addict
 
mudbuddy's Avatar
 
Join Date: Mar 2008
Location: Kenosha Wi.
Posts: 222
You will need to do a pressure test with a gauge. The procedure is spelled out in the manual.

mudbud 2006 camo rincon, kimpex buddy seat, 2.5 warn winch, warn front bumper, atv-guru rear bumper and combo hitch kit, high lifter springs, VTR spring spacers, garmin gps, Stewert Warner Temp and Volt gauges, swisher heated grips, itp terra cross rt's, full AP skid plate setup ~ 2007 Foreman power steering and ESP for the wife, Warn RT25 winch Aluminum Products skid plate hook holster, skid plate and stick guards Warn front bumper Home made rear bumper a atv guru knock off. Moose heated grips and thumb warmer, Cycle Country plow.

http://i457.photobucket.com/albums/q...rbikes-1-1.jpg
mudbuddy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome