03 Rubicon Low Range Problem - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
Reply
 
LinkBack Thread Tools
Old 09-17-2010, 09:27 AM   #1 (permalink)
Honda Rider
 
Join Date: Sep 2010
Posts: 3
Default 03 Rubicon Low Range Problem

My Rubicon won't shift when in Low Range. Everything works fine in D but in Low Range the Display doesn't show show anything in the gear indicator position. If you switch from D to L, it stays in the gear that it was in while you were in D but it doesn't show it on the display. When you move the shifter to L you get a Constant (not flasing) D1, D2, ESP in the display. Any ideas?
treed67 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-17-2010, 09:50 PM   #2 (permalink)
Honda Red Wing Rider
 
2003 foreman es's Avatar
 
Join Date: Dec 2009
Location: The Motor City
Posts: 3,664
Default

to the forum... Hmmm. I'm confused alittle. When your in drive (D), the display will show what gear your in and you can shift from one gear to the next. If you in 4 wheel low, it doesnt. Correct? And it wont shift from one gear to the next when your in low? I want to help, just not understanding the issue.
__________________
03 Foreman ES
Too much to list...
2003 foreman es is offline   Reply With Quote
Old 09-17-2010, 10:40 PM   #3 (permalink)
Honda Rider
 
Join Date: Sep 2010
Posts: 3
Default

Yes you are exactly right. In D it will shift out fine in D1 D2 or ESP. In low it just stays in whatever gear you were in when you shifted into low. I you are in D1 or D2 i stays in 1st. If you are in ESP and in any other gear it stays in that gear. I can tell it is that gear by trying to take off in higher gears and feeling the bog. It will not change gears manually or automatically when in low and it doesn't show anything at all in the gear indicator position on the display. The display shows D1, D2, and ESP all at the same time when in Low....but not flashing...just constant. It never flashes like it is having a problem.
treed67 is offline   Reply With Quote
Old 09-18-2010, 08:16 AM   #4 (permalink)
Honda Red Wing Rider
 
2003 foreman es's Avatar
 
Join Date: Dec 2009
Location: The Motor City
Posts: 3,664
Default

Ok, I have a dumb question. Is it supposed to do that? Did it shift fine, in low before?
__________________
03 Foreman ES
Too much to list...
2003 foreman es is offline   Reply With Quote
Old 09-18-2010, 09:19 AM   #5 (permalink)
Honda Rider
 
Join Date: Sep 2010
Posts: 3
Default

Yes, it used to shift fine. It is suppose operate just like D but just a lower range. I should come up on the screen and say low too.
treed67 is offline   Reply With Quote
Old 09-18-2010, 11:27 PM   #6 (permalink)
Honda Red Wing Rider
 
2003 foreman es's Avatar
 
Join Date: Dec 2009
Location: The Motor City
Posts: 3,664
Default

Have you check the electrical connections for corrosion?
__________________
03 Foreman ES
Too much to list...
2003 foreman es is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:29 PM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0