Honda Ignition Problems.... - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-03-2011, 04:45 PM Thread Starter
Honda Rider
 
Join Date: May 2010
Posts: 8
Cool Honda Ignition Problems....

Okay I have a 08 Honda Foreman 500 ES 4x4 w/ Power-steering...and I have it snorkeled out with a Triangle ATV Snorkit. When I installed the snorkel I put die electric grease in every connection I could find and sprayed the outsides with spray silicon. But after I returned from Mud Nats it started having a issue when ever you turn the key on the display doesn't come on you have to turn it off and on a few times then it will finally come on. I'm thinking water in a connection somewhere or there's a solenoid under the seat and I was wondering if that had anything to do with it. THANKS FOR YALLS HELP!!!!!
M.O.R. Mud Boyz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-03-2011, 08:48 PM
Honda Red Wing Rider
 
martdog420's Avatar
 
Join Date: Aug 2009
Location: ontario canada
Posts: 1,837
Ive never heard of that problem before and it makes me think your probably right on the water in a plug issue. I would search for error codes because sometimes they dont all flash on the dash. Ive heard of some problems with the displays on the older units but not as new as 07.
martdog420 is offline  
post #3 of 4 (permalink) Old 04-04-2011, 09:04 AM
Honda Red Wing Rider
 
Gauntlet3D's Avatar
 
Join Date: May 2010
Location: Upstate NY
Posts: 1,312
I agree it sounds like water in a connection somewhere.

2009 Rubicon Black 350 Miles
2500lbs Warn
ITP 212 Machined SS Rims
27" Maxxis Zillas
2" Gorilla Lift
Richocett Swing Arm Skid Plate
2" Snorkle
HMF Swamp Series
UniFilter
Rejet
Custom Speaker Box
Powermadd Black Hand Guards
Ammo cans

2007 Rancher ES Red 750 Miles
ITP 108 Machined SS Rims
Rubicon stock tires
Powermadd Black Hand Guards
2 Up Rear Box
Gauntlet3D is offline  
post #4 of 4 (permalink) Old 04-05-2011, 12:41 PM Thread Starter
Honda Rider
 
Join Date: May 2010
Posts: 8
Alright well I'm at school during the week and I will be headed home this weekend and I'm going to check it out. Hopefully I can find the wet connection. It's about to for me to pull all the plastic off again and just re-grease everything like I did the first time when I installed the snorkel. Thanks for the info guys!!!

If anybody has anything else to had please feel free to, I'm open to ideas....
M.O.R. Mud Boyz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome