Honda Ignition Problems.... - Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
Honda Foreman Forums : Rubicon, Rincon, Rancher and Recon Forum
Reply
 
LinkBack Thread Tools
Old 04-03-2011, 05:45 PM   #1 (permalink)
Honda Rider
 
Join Date: May 2010
Posts: 8
Cool Honda Ignition Problems....

Okay I have a 08 Honda Foreman 500 ES 4x4 w/ Power-steering...and I have it snorkeled out with a Triangle ATV Snorkit. When I installed the snorkel I put die electric grease in every connection I could find and sprayed the outsides with spray silicon. But after I returned from Mud Nats it started having a issue when ever you turn the key on the display doesn't come on you have to turn it off and on a few times then it will finally come on. I'm thinking water in a connection somewhere or there's a solenoid under the seat and I was wondering if that had anything to do with it. THANKS FOR YALLS HELP!!!!!
M.O.R. Mud Boyz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-03-2011, 09:48 PM   #2 (permalink)
Honda Red Wing Rider
 
martdog420's Avatar
 
Join Date: Aug 2009
Location: ontario canada
Posts: 1,815
Default

Ive never heard of that problem before and it makes me think your probably right on the water in a plug issue. I would search for error codes because sometimes they dont all flash on the dash. Ive heard of some problems with the displays on the older units but not as new as 07.
martdog420 is offline   Reply With Quote
Old 04-04-2011, 10:04 AM   #3 (permalink)
Honda Red Wing Rider
 
Gauntlet3D's Avatar
 
Join Date: May 2010
Location: Upstate NY
Posts: 1,312
Default

I agree it sounds like water in a connection somewhere.
__________________
2009 Rubicon Black 350 Miles
2500lbs Warn
ITP 212 Machined SS Rims
27" Maxxis Zillas
2" Gorilla Lift
Richocett Swing Arm Skid Plate
2" Snorkle
HMF Swamp Series
UniFilter
Rejet
Custom Speaker Box
Powermadd Black Hand Guards
Ammo cans

2007 Rancher ES Red 750 Miles
ITP 108 Machined SS Rims
Rubicon stock tires
Powermadd Black Hand Guards
2 Up Rear Box
Gauntlet3D is offline   Reply With Quote
Old 04-05-2011, 01:41 PM   #4 (permalink)
Honda Rider
 
Join Date: May 2010
Posts: 8
Default

Alright well I'm at school during the week and I will be headed home this weekend and I'm going to check it out. Hopefully I can find the wet connection. It's about to for me to pull all the plastic off again and just re-grease everything like I did the first time when I installed the snorkel. Thanks for the info guys!!!

If anybody has anything else to had please feel free to, I'm open to ideas....
M.O.R. Mud Boyz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:07 PM.




Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0